MODULE OVERVIEW

LESSON 1: CHANGING THE APPEARANCE OF THE PORTAL

LESSON 2: EDITING A PAGE

LESSON 3: WORKING WITH WEB PARTS AND APP PARTS

LESSON 4: TARGETING AUDIENCES WITH CONTENT

LAB 1: ADDING AND CONFIGURING WEB PARTS

LAB 2: CONNECTING WEB PARTS

LAB 3: APPLYING THEMES TO YOUR COMPANY PORTAL

Module Overview

This module explains how to design a company portal using out-of-the-box web parts and themes in SharePoint 2016.

After completing this module, students will be able to:

• Implement themes and add a logo
• Add web parts to pages
• Leverage audiences for targeting content

Lesson 1: Changing the Appearance of the Portal

SharePoint 2016 offers site and site collection administrators the ability to adjust the style of their SharePoint using a set of predefined looks within SharePoint 2016. These styles also include colors for hyperlinks, fonts, headings and body content. Customizing the theme is the beginning of branding a site. Branding applies a distinct visual identity to the site in order to make SharePoint visually recognizable as a company asset.

Although some of the more advanced branding features are beyond the scope of this course, the following are some small steps that can be taken in that direction.

Applying a Theme

1. Navigate to the desired site.

2. Click Settings > Site Settings > Look and Feel > Change the look.
Changing the look

3. The **Design Gallery** opens with a variety of predefined layouts.

   Selecting a predefined layout is just a starting point. It does not imply there will be no opportunity to adjust the color, font or graphic images after it is created.

4. Click the **Orange** template.

Choosing a template

5. The **Design Builder** page opens, allowing site collection and site owners to adjust the colors, site layout and fonts plus apply a background image.
Applying a look

6. Click the **Colors** drop-down to scroll through the list of predefined colors. Notice while scrolling through the colors, the preview site will update showing the applied palette.

7. Click the **Site Layout** drop-down and select the **Oslo** layout.

8. Review the updated layout.

9. Click **Change** under the image placeholder to browse and upload a background image.

10. Review the updated layout with the screened background image.

11. To apply the updated look, click **Try it out**.
Trying a new look

12. A preview of the updated theme renders with the option to keep the look or make adjustments. Click Yes, I'll keep it.

Reviewing a look

Adding a Custom Logo

A simple branding element, which many companies can leverage, is the logo. The default SharePoint logo can quickly be switched out in favor of a company logo.

1. Click Settings > Site Settings > Look and Feel > Title, description, and logo.

Adding a logo

2. In the Logo and Description section, click either From Computer or From SharePoint to locate an image.
3. Click OK.

4. Review the site to confirm the logo fits appropriately on the site.

Best Practices for Working with Themes

Administrators should:

- Create a consistent theme across all sites. It may confuse the end user if there is a drastic variation in themes.
- Create a site template with the theme already applied prior to creating new sites.

Lesson 2: Editing a Page

The home page, created as part of a team site, is based upon Wiki pages, giving site administrators the ability to customize the home pages for various team sites. Multiple pages can be created for a site, and stored in the Site Pages library, allowing for the creation of different landing pages for a site. Also, if a site owner or site collection administrator wants to develop a new home page, the old home page can remain in place until the new one is finished.

Editing a Page

1. Navigate to the desired site.

2. Click Edit in the global toolbar.

   Editing a page

   Notice the ribbon has two additional tabs – one for text formatting and the other for inserting objects onto the page.
Creating and Assigning a New Home Page for a Site

1. Navigate to the desired site.
2. Click Add a Page.
3. Click Page > Make Homepage from the Page Actions section.

Assigning a new home page

Changing the Layout of the Page

The default layout consists of a header content placeholder with two columns directly below. This layout may work for many sites. However, site owners may determine that this layout does not support the amount of content desired on the home page. The Text Layout feature provides different areas on the page to be completed.

1. Navigate to the desired site.
2. Click Edit in the global toolbar.
3. Click Format Text > Text Layout from the Layout section.

Changing the layout of a page

4. Select an alternate layout from the drop-down menu.
5. Notice the page layout updates to include additional columns or rows.
6. Click Format Text > Save from the Edit group.

Lesson 3: Working with Web Parts and App Parts
Web parts are modular SharePoint objects that form the basic building blocks of a SharePoint page. They act as placeholders for content to be displayed on the page. Web parts can be built by developers to retrieve data from a number of different sources. An app part is a web part that is related to a specific piece of SharePoint content such as a list, library or custom developed application.

Throughout this lesson, the term web part will be used. It is important to note that app parts behave in the same manner; they are connected to a specific piece of SharePoint content such as a list, library or custom developed solution.

Both web parts and app parts can be placed on web part pages or on the portal page for a site collection. SharePoint lists and libraries, when created, generate default List View Web Parts, to be used to display the contents of that list or library. SharePoint pages can display custom app parts to help create a story about the site or present a specific set of information.

Web Part Components

There are some key terms that are important to know when working with web parts.

1. The web part **Title Bar** contains the heading for the web part.
2. The **body** of the web part contains the content for that specific web part. In the previous example, the Image Web Part displays an image.
3. The **Web Part Menu** gives some functionality for the web part. This includes minimizing, closing, modifying and exporting the web part. The **Edit Web Part** menu option allows the web part properties to be configured or modified.

Web Part Page

A web part page is a special type of SharePoint web page that facilitates the adding and managing of web parts. A SharePoint administrator or user can add multiple web parts to help consolidate information into one place. Examples of web part pages include the site home page and the portal page of a site collection.

Depending upon what type of site has been created, there may be web part pages associated.
**Web Part Zones**

Web part zones can be included within each web part page. A zone divides the page into areas that allow SharePoint users to place a web part on the page. For example, the default team site home page has two web part zones – left and right. Web part pages have multiple web part zones depending on the type of page selected.

Web parts can be locked down, or placed outside a web part zone, allowing the administrator to keep web parts from being moved between zones. To define zones or to lock down web parts, a separate tool such as SharePoint Designer 2013 must be used.

**Using Web Parts Together**

Web parts can be connected to each other to help create a SharePoint application displaying specific information. Below is an example of what can be created in SharePoint using web parts and connections.

1. Look up an order by **Order ID** or **Date**.
2. Display all orders by date.
3. Select the correct order, based on the customer's name, and look up order details such as the customer's contact person.
4. Select a line item in the order and display a product picture.
5. Scan for business news that may affect a customer's order.

![Connecting web parts](image)

**Web Part Inventory**

The web part inventory depends on which version of SharePoint is deployed – SharePoint Foundation, SharePoint Server Standard or SharePoint Server Enterprise. Some web parts may require external data connections, such as the Business Data Catalog Web Parts or Filter Web Parts.

When inserting a web part on a page, SharePoint presents them in groups. Following is an overview of the groups and descriptions of the various web parts.
Apps

These web parts are built into the SharePoint 2016 site templates and are based on any default or custom lists or libraries within SharePoint.

<table>
<thead>
<tr>
<th>List or Library Web Part</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Announcements</td>
<td>Posts news, statuses and brief information for team members.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Displays upcoming events or schedules.</td>
</tr>
<tr>
<td>Contacts</td>
<td>Displays data from a contacts list.</td>
</tr>
<tr>
<td>Content and Structure Reports</td>
<td>Uses the reports list to customize queries that appear in the Content and Structure Tool views.</td>
</tr>
<tr>
<td>Documents</td>
<td>Shares files from the default Document Library within the site.</td>
</tr>
<tr>
<td>Form Templates</td>
<td>Contains administrator-approved form templates that were activated to this Site Collection. This is a library.</td>
</tr>
<tr>
<td>Links</td>
<td>Displays links to other web pages for the team.</td>
</tr>
<tr>
<td>Microfeed</td>
<td>Displays a feed from the MySite Microsoft persistent storage list.</td>
</tr>
<tr>
<td>Site Assets</td>
<td>Uses this document to store files that are included on pages within this site, such as images on Wiki Pages.</td>
</tr>
<tr>
<td>Site Pages</td>
<td>Uses this library to create and store pages on this site.</td>
</tr>
<tr>
<td>Tasks</td>
<td>Displays tasks that are assigned to a member of the team. These tasks can display due date and priority, as well as status and progress.</td>
</tr>
<tr>
<td>Workflow Tasks</td>
<td>Stores workflow tasks that are created in this site. This System Library was created by the Publishing feature.</td>
</tr>
</tbody>
</table>

Blog

These web parts provide the ability to access information within a blog site in SharePoint.

<table>
<thead>
<tr>
<th>Blog Web Part</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blog Archives</td>
<td>Provides quick links to older blog posts.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Blog Notifications</td>
<td>Provides quick links to register for blog posts notifications using Alerts or RSS feed.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Blog Tools</td>
<td>Provides blog owners and administrators with quick links to common settings pages and content lists for managing a blog site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
</tbody>
</table>

Business Data

These web parts provide the ability to access SharePoint data internally or externally. Most of these web parts connect to external data via the Business Data Catalog (BDC). The BDC is a published list of connections to different data sources such as SQL, Oracle, SAP, etc. This allows SharePoint, SharePoint Designer and other applications (such as InfoPath) to tap into this information without having to create separate data connections. Other web parts connect to Excel Services and Visio Services.

<table>
<thead>
<tr>
<th>Business Data Web Part</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business Data Actions</td>
<td>Displays a list of actions from the BDC.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Business Data Connectivity Filter</td>
<td>Filters the content of web parts using a list of values from the Business Data Connectivity.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Business Data Item</td>
<td>Displays one item from a data source in the BDC.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Business Data Web Part</td>
<td>Description</td>
<td>Version</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Business Data Item Builder</td>
<td>Creates a Business Data item from parameters in the query string and provide it to other web parts. This web part is only used on Business Data profile pages.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Business Data List</td>
<td>Displays a list of items from a data source in the BDC.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Business Data Related List</td>
<td>Displays a list of items related to one or more parent items from a data source in the BDC.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Excel Web Access</td>
<td>Uses the Excel Web Access to interact with an Excel workbook as a web page.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Indicator Details</td>
<td>Displays the details of a single status indicator. Status indicators display an important measure for an organization and may be obtained from other data sources including SharePoint lists, Excel workbooks, and SQL Server Analysis Services KPIs.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Status List</td>
<td>Displays a list of status indicators. Status indicators display important measurements for the organization and show how the organization is performing with respect to goals.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>Visio Web Access</td>
<td>Enables viewing and refreshing of Visio Web Drawings.</td>
<td>Enterprise</td>
</tr>
</tbody>
</table>

### Community

These web parts display information about a community site. Each of these web parts will work on community sites or any other site that has community features turned on.

<table>
<thead>
<tr>
<th>Community Web Parts</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>About this community</td>
<td>Displays the community description and other properties like established date.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Join</td>
<td>Provides the ability for non-members of a community site to join the community; the button hides itself if the user is already a member.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>My membership</td>
<td>Displays reputation and membership information for the current visitor of a community site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Tools</td>
<td>Provides community administrators with quick links to common settings pages and content lists for managing a community site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>What’s happening</td>
<td>Displays the number of members, topics and replies within a community site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
</tbody>
</table>

### Content Roll-Up Web Part

These web parts allow users to aggregate information into one location.

<table>
<thead>
<tr>
<th>Content Roll-up Web Part</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Categories</td>
<td>Displays categories from the Site Directory.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Content Query</td>
<td>Displays a dynamic view of content from the site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Content Search</td>
<td>Displays a dynamic view of content from the site based upon a search query.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Project summary</td>
<td>Displays project information in an overview.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Relevant Documents</td>
<td>Displays documents that are relevant to the current user.</td>
<td>All Versions</td>
</tr>
<tr>
<td>RSS Viewer</td>
<td>Displays an RSS feed.</td>
<td>Standard &amp; Enterprise</td>
</tr>
</tbody>
</table>
## Content Roll-up Web Part

<table>
<thead>
<tr>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Aggregator Displays site of choice.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Sites in Category Displays sites from the Site Directory within a specific category.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Summary Links Allows authors to create links that can be grouped and styled.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Table of Content Displays the navigation hierarchy of the site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Term Property Displays the specified property of a specific term.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Timeline Shows a high level view of data from another web part or tasks list.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>WSRP Viewer Display portlets from websites using WSRP 1.1.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>XML Viewer Transforms XML data using XSL and shows the results.</td>
<td>All Versions</td>
</tr>
</tbody>
</table>

### Document Sets

These web parts are used to display information specifically about document sets found within that site.

<table>
<thead>
<tr>
<th>Document Sets</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document Set Content Displays the content of a Document Set.</td>
<td>Standard &amp; Enterprise</td>
<td></td>
</tr>
<tr>
<td>Document Set Properties Displays the properties of a Document Set.</td>
<td>Standard &amp; Enterprise</td>
<td></td>
</tr>
</tbody>
</table>

### Filters

The purpose of Filter web parts is to connect with other web parts and filter content.

<table>
<thead>
<tr>
<th>Filters</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply Filters Button When added to a page, it allows users to decide when to apply their filter choices, otherwise, each filter is applied when its value is changed.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Choice Filter Filters the contents of web parts using a list of values entered by the page author.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Current User Filter Filters the contents of web parts by using properties of the current user.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Date Filter Filters the contents of web parts by allowing users to enter or pick a date.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Page Field Filter Filters the contents of web parts using information about the current page.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Query String (URL) Filter Filters the contents of web parts using values passed via the query string.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>SharePoint List Filter Filters the contents of web parts by using a list of values.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>SQL Server Analysis Services Filter Filters the contents of web parts using a list of values from SQL Server Analysis Services cubes.</td>
<td>Enterprise</td>
<td></td>
</tr>
<tr>
<td>Text Filter Filters the contents of web parts by allowing users to enter a text value.</td>
<td>Enterprise</td>
<td></td>
</tr>
</tbody>
</table>

### Forms

These web parts are used to display forms to be utilized within a web page.
MODULE 5 Working with Pages and Web Parts

<table>
<thead>
<tr>
<th>Forms</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Form Web Part</td>
<td>Connects simple form controls to other web parts.</td>
<td>All Versions</td>
</tr>
<tr>
<td>InfoPath Form Web Part</td>
<td>Displays an InfoPath browser-enabled form.</td>
<td>Enterprise</td>
</tr>
</tbody>
</table>

**Media and Content**

These web parts are used to display media content within a page. Media content can include audio, video or images.

<table>
<thead>
<tr>
<th>Media and Content</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Editor</td>
<td>Allows authors to enter rich text content.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Getting started with your site</td>
<td>Displays a set of tiles with common SharePoint actions.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Image Viewer</td>
<td>Displays a specified image.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Media Web Part</td>
<td>Embeds media clips (video and audio) in a web page.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Page Viewer</td>
<td>Displays another web page on this web page, the other web page is presented in an iframe.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Picture Library Slide Show Web Part</td>
<td>Displays a slideshow of images and photos from a picture library.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Script editor</td>
<td>Allows authors to insert HTML snippets or scripts.</td>
<td>All Versions</td>
</tr>
<tr>
<td>Silverlight Web Part</td>
<td>Displays a Silverlight application.</td>
<td>All Versions</td>
</tr>
</tbody>
</table>

**PerformancePoint**

These web parts are used to display PerformancePoint reports, scorecards and related information in SharePoint. These parts are available on sites created with the Business Intelligence Center template or on sites with the PerformancePoint features enabled.

<table>
<thead>
<tr>
<th>PerformancePoint</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>PerformancePoint Filter</td>
<td>Displays PerformancePoint filters. Filters may be linked to other web parts to provide an interactive dashboard experience. Filter types include lists and trees based on a variety of data sources.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>PerformancePoint Report</td>
<td>Displays PerformancePoint reports. Reports may be linked to other web parts to create an interactive dashboard experience. Report types include: Analytic charts and grids, strategy maps, Excel Services, Reporting Services, predictive trend charts and web pages.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>PerformancePoint Scorecard</td>
<td>Displays a PerformancePoint scorecard. Scorecards may be linked to other web parts, such as filters and reports, to create an interactive dashboard experience.</td>
<td>Enterprise</td>
</tr>
<tr>
<td>PerformancePoint Stack Selector</td>
<td>Displays a PerformancePoint stack selector. All PerformancePoint web parts, such as filters and reports, contained in the same zone will be automatically stacked and selectable using this web part.</td>
<td>Enterprise</td>
</tr>
</tbody>
</table>

**Search**

These web parts are used to input and display information associated with Search and Search Results.
## Search-Driven Content

These web parts are used to input and display information associated with Search and Search Results. As new content is discovered by search, the web part displays an updated list of items each time the page is viewed. When these web parts are added to the page, they display items from the current site. Administrators change this setting to show items from another site or list by editing the web part, and by changing its search criteria.

### Search-Driven Content Table

<table>
<thead>
<tr>
<th>Search</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find by Document ID</td>
<td>Finds a document by its Document ID.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Refinement</td>
<td>Helps users to refine people search results.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Search Box</td>
<td>Displays a search box that allows users to search for information.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Search Navigation</td>
<td>Helps the users to navigate among search verticals.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Search Results</td>
<td>Displays the search results and the properties associated with them.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Taxonomy Refinement</td>
<td>This web part helps the user to refine search results on term set data. To use this web part, a Search Data Provider web part must be on this page, and Managed Navigation must be used.</td>
<td>Standard &amp; Enterprise</td>
</tr>
</tbody>
</table>

### Social Collaboration

These web parts are used to display social information related to My Sites and user profile service.

### Social Collaboration Table

<table>
<thead>
<tr>
<th>Social Collaboration</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Details</td>
<td>Displays details about a contact for this page or site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Note Board</td>
<td>Enables users to leave short, publicly-viewable notes about this page.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Organization Browser</td>
<td>Displays each person in the reporting chain in an interactive view optimized for browsing organization charts.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Site Feed</td>
<td>Contains microblogging conversations on a group site.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>Site Users</td>
<td>Displays a list of the site users and their online status.</td>
<td>All Users</td>
</tr>
<tr>
<td>Social Collaboration</td>
<td>Description</td>
<td>Version</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Tag Cloud</td>
<td>Displays the most popular subjects being tagged inside an organization.</td>
<td>Standard &amp; Enterprise</td>
</tr>
<tr>
<td>User Tasks</td>
<td>Displays tasks that are assigned to the current user.</td>
<td>All Users</td>
</tr>
</tbody>
</table>

**SQL Reporting Services**

These web parts are used to display SQL Server Reporting Services Reports in a web page.

<table>
<thead>
<tr>
<th>SQL Server Reporting Services Report Viewer</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Reporting Services Report Viewer</td>
<td>Uses the Report Viewer to view SQL Server Reporting Services reports.</td>
<td>Enterprise</td>
</tr>
</tbody>
</table>

**Managing a Web Part on a Page**

Within SharePoint 2016, there are many types of pages used to display a web part including Wiki pages, web part pages and web content pages.

As discussed in previous sections, the SharePoint Welcome page and other site pages are based on the SharePoint Wiki page. This allows a SharePoint site administrator the ability to add a web part into a page without having an associated web part zone. This does not allow a typical SharePoint user the ability to move web parts around from one part of the page to another.

**Adding Web Parts into Pages**

1. Navigate to the desired page.
2. Click **Edit** in the global toolbar.
3. On a web part page, click **Add a Web Part** in the desired web part zone. Otherwise, place the cursor where the web part is to be inserted, and click **Insert > Web part** from the **Parts** section. A web part selection window opens below the ribbon.
4. Click the desired category and web part and then click **Add**.
5. To stop editing click **Page > Save** from the **Edit** group.

**Export a Web Part**
Once a web part is configured, it is possible to export in order to use in a different location within SharePoint. Not all web parts can be exported because of data connections or permissions that may need to be modified. All exported web parts are saved as .webpart or .dwp.

1. Navigate to the desired Wiki Page or Web Part Page.
2. Click Edit in the global toolbar.
3. Hover over the Web Part menu and click Export.

**Exporting a web part**

4. Click OK in the SharePoint dialog.
5. Click Save in the File Download window.

**Saving a web part**

6. Save the file locally and remember the location.

### Import a Web Part

Importing a web part can be used to add exported web parts or third party web parts that have been purchased.

1. Navigate to the desired SharePoint location.
2. Click Edit in the global toolbar.
3. Click Insert > Web Part > from the Parts section and then select Upload a Web Part.
Uploading a web part

4. Click the Browse button. Locate the desired .webpart and click Open.

5. Finalize the upload by clicking the Upload button.

Browse for the web part

6. Click OK to save the page. When SharePoint refreshes, click into Insert > Web Part from the Parts section.

7. There should be a new category called Imported Web Parts. Click Add to add the web part to the SharePoint page.

Viewing the new web part

Remove Web Part from Page

1. Navigate to the desired SharePoint location and click Edit in the global toolbar.

2. Click the Web Part header (on the actual web part itself) and then navigate to Web Part > Delete from the State group.
Deleting a web part

OR

Hover over the Web Part menu and click Delete.

Deleting from a web part

3. A dialog box will appear requesting confirmation to permanently delete this web part. Click OK.

4. To finish click Page > Save from the Edit group.

Customizing a Web Part

All web parts have a common set of properties that control their appearance, layout and advanced characteristics. Depending on which permissions have been granted, users may or may not be able to change them. Web part developers may also have chosen not to display one or more of these properties as they created the web part.

To access the properties of a web part, perform one of the following set of steps:

1. Navigate to the desired SharePoint page

2. Click Edit in the global toolbar.

3. Click the desired web part header.

4. Click Web Part > Web Part Properties from the Properties section.

Accessing web part properties
The web part properties window should appear on the right-hand portion of the SharePoint page.

Accessing properties from the web part

All web parts have, at minimum, Appearance properties, Layout properties and Advanced properties available within the properties window. Depending upon the type of web part, there will be other properties that will need to be configured to allow the web part to work properly.

Appearance Properties

<table>
<thead>
<tr>
<th>Appearance Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Specifies the title of a web part, which appears in the web part title bar.</td>
</tr>
<tr>
<td>Height</td>
<td>Specifies the height of the web part.</td>
</tr>
<tr>
<td>Width</td>
<td>Specifies the width of the web part.</td>
</tr>
<tr>
<td>Chrome State</td>
<td>Specifies whether the entire web part appears on the page when a user opens the web part page. By default,</td>
</tr>
</tbody>
</table>
this is set to Normal and the whole web part appears. Only the title bar appears when it is set to Minimized.

### Layout Properties

<table>
<thead>
<tr>
<th>Layout Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hidden</td>
<td>Specifies whether a web part is visible when a user opens the web part page. When selected, the web part title bar is added (Hidden). This is typically done to help provide data to another web part through a web part connection.</td>
</tr>
<tr>
<td>Direction</td>
<td>Specifies the direction of the text in the web part content. For example: English is a left-to-right language; however, Arabic is a right-to-left language.</td>
</tr>
<tr>
<td>Zone</td>
<td>Specifies the zone on the web part page where the web part is located. <strong>Note:</strong> Zones in web part pages are not listed if the person does not have permission to modify the zone.</td>
</tr>
<tr>
<td>Zone Index</td>
<td>Specifies the position of the web part in a zone when the zone contains more than one web part. This is done using ordering. If the web parts in the zone are ordered from top to bottom, a value of one means the web part appears at the top of the zone. If they are left to right, then the value of one means the web part appears on the left of the zone. <strong>Note:</strong> Each web part in a zone must have a unique zone index value. Therefore, by changing the zone index for one will also change the zone index for other web parts within that zone.</td>
</tr>
</tbody>
</table>

### Advanced Properties

<table>
<thead>
<tr>
<th>Advanced Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Minimize</td>
<td>Specifies whether the web part can be minimized.</td>
</tr>
<tr>
<td>Allow Close</td>
<td>Specifies whether the web part can be removed from the web part page.</td>
</tr>
<tr>
<td>Allow Hide</td>
<td>Specifies whether the web part can be hidden.</td>
</tr>
<tr>
<td>Allow Zone Change</td>
<td>Specifies whether the web part can be moved to a different zone on the web part page.</td>
</tr>
<tr>
<td>Allow Connections</td>
<td>Specifies whether the web part can participate in connections with other web parts.</td>
</tr>
<tr>
<td>Allow Editing in Personal View</td>
<td>Specifies whether the web part can be modified in a personal view.</td>
</tr>
<tr>
<td>Title URL</td>
<td>Specifies the URL of a file containing additional information about the web part. The file is displayed in a separate browser window when the web part title is clicked.</td>
</tr>
<tr>
<td>Description</td>
<td>Specifies the screen tip that appears when the mouse pointer rests on the title or icon. The value of this can be seen when searching for web parts by using the Search command on the Find Web Part menu of the tool pane.</td>
</tr>
<tr>
<td>Help URL</td>
<td>Specifies the location of a file containing Help information about the web part. This will be displayed in a separate browser window.</td>
</tr>
</tbody>
</table>
| Help Mode           | Specifies how a browser will display Help content for a web part:  
  - **Modal:** Opens a separate browser window, if the browser has the capability. A user must close the window before returning to the web page.  
  - **Modeless:** Opens a separate window, if the browser has the capability. A user does not have to close the window to return to the web page. This is the default setting.  
  - **Navigate:** Opens the web page in the current browser window. |
| Catalog Icon Image URL | Specifies the location of a file containing an image to be used as the web part icon in the web part list. The image size must be 16x16 pixels. |
| Title Icon Image URL | Specifies the location of a file containing an image to be used in the web part title bar. The image size must be 16x16 pixels. |
| Import Error Message | Specifies a message that appears if there is a problem importing the web part. |
| Target Audience     | Specifies which group has permissions to see the web part. |
AJAX Options

<table>
<thead>
<tr>
<th>AJAX Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Asynchronous Load</td>
<td>Used for loading data either asynchronously (continue working while the data loads) or synchronously (the web part displays a &quot;loading&quot; image until the all the data is returned from the server).</td>
</tr>
<tr>
<td>Enable Asynchronous Update</td>
<td>Used to enable or disable asynchronous or synchronous behavior for the following operations: sorting, paging, filtering, and refresh.</td>
</tr>
<tr>
<td>Show Manual Refresh Button</td>
<td>Used to display or hide a button to manually refresh the web part view.</td>
</tr>
<tr>
<td>Enable Asynchronous Automatic Refresh</td>
<td>Used to enable or disable automatically refreshing the web part view.</td>
</tr>
<tr>
<td>Automatic Refreshing Interval (seconds)</td>
<td>Used to specify the time interval between each automatic refresh operation. The default value is 60 seconds.</td>
</tr>
</tbody>
</table>

Miscellaneous Options

<table>
<thead>
<tr>
<th>Miscellaneous Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Data</td>
<td>Administrators can enter sample data as a valid XML file and with the same structure as the data returned by the data source. A SharePoint compatible editor, such as Microsoft SharePoint Designer 2013, can use the sample XML data specified by this property to render the Data View at design time.</td>
</tr>
<tr>
<td>XSL Link</td>
<td>Used to enter XSLT source code into a plain text editor. Knowledge of XSLT syntax is required to use this editor.</td>
</tr>
<tr>
<td>Enable Data View Caching</td>
<td>Used to cache or not cache the XSL transform as well as the Data Source Control instance.</td>
</tr>
<tr>
<td>Data View Caching Time-out (seconds)</td>
<td>Used to specify the duration in seconds for clearing the cache. Selecting 0 sets this property to the default value of 86,400 seconds (which is one day).</td>
</tr>
<tr>
<td>Send first row to connected Web Parts when page loads</td>
<td>Used to send or not send the first row of data to one or more connected web parts when the page loads.</td>
</tr>
<tr>
<td>Server Render</td>
<td>Used to disable client-side rendering of the Data View Web Part. This also hides the View Selector menu, Save This View button, and Display Search Box properties noted in the following entries.</td>
</tr>
<tr>
<td>Disable view selector menu</td>
<td>Used to show or hide the View menu … above the list column headers.</td>
</tr>
</tbody>
</table>

Content Rollup Web Parts

As mentioned in the Web Part Inventory section, there are many different types of web parts available within the different versions of SharePoint. This category represents web parts that can summarize or display aggregate
information for internal SharePoint information or external data sources. This section will cover:

- Content Query Web Part
- Search Query Web Part

**Content Query Web Part**

The Content Query Web Part is used to display a dynamic view of content from a site. This can include information from lists, libraries or web pages that can be queried. Modifying the properties enables users to better narrow their search. This web part is popular because it is customizable.

Querying can be done against the site collection, site, list/library, or content type. Other properties include presentation, styles and feeds, along with the standard properties for web parts.

1. After a Content Query Web Part is added, select **Edit Web Part** from the **Web Part** drop-down menu.

2. Expand the **Query** section of the tool pane and configure.

<table>
<thead>
<tr>
<th>Query Section</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Show items from all sites in this site collection</td>
<td>This section performs the query starting at the site collection on down through all Sites.</td>
</tr>
<tr>
<td>Show items from the following site and all sub-sites</td>
<td>This section performs the query starting at a site and includes all subsites.</td>
<td></td>
</tr>
<tr>
<td>Show items from the following list</td>
<td>This section includes lists and libraries within a site and all sites within the Site collection are available.</td>
<td></td>
</tr>
<tr>
<td>List Type</td>
<td>Show items from this list type</td>
<td>The query is narrowed to focus on a certain list type if query focus is either at the site collection or site level.</td>
</tr>
<tr>
<td>Content Type</td>
<td>Show items in this content type group or show items in this content type</td>
<td>These sections allow the user to narrow down the focus to a particular site content type. All content types are available to choose from at the site collection and site levels.</td>
</tr>
<tr>
<td>Include child content types</td>
<td>This will include a child content type when returning the query results.</td>
<td></td>
</tr>
<tr>
<td>Audience Targeting</td>
<td>Apply audience filtering</td>
<td>Allows for audience targeting from within the list or library. SharePoint users who have permissions to view the item will be able to view and edit the document based on permissions.</td>
</tr>
<tr>
<td>Include items that are not targeted</td>
<td>In addition to the audience targeted documents, all other documents will be available.</td>
<td></td>
</tr>
<tr>
<td>Navigation Context</td>
<td>Filter by page navigation term</td>
<td>Allows the ability to filter the contents in the Content Query Web Part by a term used for page navigation.</td>
</tr>
<tr>
<td>Additional Filters</td>
<td>Show items when...(filter conditions)</td>
<td>These filters provide the ability to add conditional statements (e.g., and, or, etc.) to filter the content to a specific outcome.</td>
</tr>
</tbody>
</table>

3. Expand the **Presentation** section of the tool pane and configure.

<table>
<thead>
<tr>
<th>Presentation Section</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Presentation Section</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Grouping and Sorting</td>
<td>Group items by</td>
<td>Used to group items by and choose whether or not it should be ascending or descending. There is also an option to show the information in multiple columns.</td>
</tr>
<tr>
<td></td>
<td>Sort items by</td>
<td>This is similar to how sorting works in views. Choose a column to sort items by and choose whether or not it should be ascending or descending.</td>
</tr>
<tr>
<td></td>
<td>Limit the number of items to display / Item Limit</td>
<td>Used to decide how many items to display within the web part.</td>
</tr>
<tr>
<td>Styles</td>
<td>Group Style</td>
<td>As the data is being presented, what should it look like?</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Default: Information is in a list view.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• An option exists for large text or small text.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Banded: Group headers are banded.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Centered: Group headers are centered in the web part.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Separator: The rule is used to separate the groups from each other.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Whitespace: Used to add white between groups.</td>
</tr>
<tr>
<td></td>
<td>Item Style</td>
<td>This option deals specifically with title, description, image and the desired combination.</td>
</tr>
<tr>
<td>Fields to display</td>
<td>Link, Image, Title, Description</td>
<td>Used to complete these various fields that correspond with existing fields within the site collection, site or list to be displayed.</td>
</tr>
<tr>
<td>Feed</td>
<td>Enable feed for this web part</td>
<td>This option enables RSS for this specific web part.</td>
</tr>
<tr>
<td></td>
<td>Feed title</td>
<td>This is the title for the RSS feed when in the RSS Reader.</td>
</tr>
<tr>
<td></td>
<td>Feed description</td>
<td>This option gives more information about the RSS feed.</td>
</tr>
</tbody>
</table>

4. After the configuration is complete, click OK to view the query results.

5. To stop editing, click Page > Save.

**Content Search Web Part**

The Content Search Web Part is used to display a dynamic view of content based upon a search query that indexes content throughout a site. Display templates are snippets of HTML and JavaScript that control how the search results appear on the page. Information that can be rendered using the Content Search Web Part includes content that can be queried across site collections, sites, lists or libraries.

> The Content Search Web Part returns content that is as fresh as the latest crawl of the content. If instant content or the refreshed version of content is preferred, use the Content Query Web Part (CQWP) instead.

1. Navigate to the desired site.
2. Click **Edit** in the global toolbar.

3. Click **Insert > Web Part** from the **Parts** section.

4. Click **Content Rollup > Content Search > Add** to insert the web part into the page.

   ![Adding the content search web part](https://skillpipe.com/#/reader/urn:uuid:9e691a33-42d3-4176-b322-412dee76a30f@2022-02-23T14:00:00Z/content)

   **Adding the content search web part**

5. Click **Edit Web Part** on web part menu.

   ![Editing the web part](https://skillpipe.com/#/reader/urn:uuid:9e691a33-42d3-4176-b322-412dee76a30f@2022-02-23T14:00:00Z/content)

   **Editing the web part**

<table>
<thead>
<tr>
<th>Query Section</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Search Criteria</td>
<td>Ability to define the scope of the search query (See following table for an explanation of the Search Criteria page)</td>
</tr>
<tr>
<td></td>
<td>Number of items to show</td>
<td>Ability to control the number of items that are returned in search results</td>
</tr>
<tr>
<td>Display Templates</td>
<td>Control</td>
<td>List of available display templates that control the presentation of the search results</td>
</tr>
<tr>
<td></td>
<td>Item</td>
<td>List of available display templates for the individual items that are displayed in the search results within the web part</td>
</tr>
<tr>
<td></td>
<td>Don’t show anything when</td>
<td>Ability to determine the behavior of the web part if no items are found</td>
</tr>
<tr>
<td></td>
<td>there are no results</td>
<td></td>
</tr>
<tr>
<td>Property Mappings</td>
<td>Change the mapping of</td>
<td>Ability to check the default mapping options configured with the display template selected</td>
</tr>
<tr>
<td></td>
<td>managed properties for the fields in the Item Display Template</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Picture URL</td>
<td>List of available Managed Properties that can be associated with the Picture URL attribute in the display template</td>
</tr>
<tr>
<td></td>
<td>Link URL</td>
<td>List of available Managed Properties that can be associated with the Path attribute in the display template</td>
</tr>
<tr>
<td></td>
<td>Line 1</td>
<td>List of available Managed Properties that can be associated with the Line 1 attribute in the display template</td>
</tr>
<tr>
<td></td>
<td>Line 2</td>
<td>List of available Managed Properties that can be associated with the Line 2 attribute in the display template</td>
</tr>
</tbody>
</table>
### Query Section

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line 3</td>
<td>List of available Managed Properties that can be associated with the Line 3 attribute in the display template</td>
</tr>
</tbody>
</table>

### Settings

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query results provided by</td>
<td>Ability to determine the source of the search results</td>
</tr>
<tr>
<td>Results Table</td>
<td>Ability to choose which results set to use in the web part</td>
</tr>
<tr>
<td>Start displaying results from result number</td>
<td>Ability to identify the starting item number for the results</td>
</tr>
<tr>
<td>Alternate Error Message</td>
<td>Ability to create a custom error message in an unlikely event that an error occurs</td>
</tr>
</tbody>
</table>

### Search Criteria

<table>
<thead>
<tr>
<th>Search Criteria</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basics</td>
<td>Select a query</td>
<td>Administrators choose the content to search by selecting a result source.</td>
</tr>
<tr>
<td>Restrict by app</td>
<td>Results can be narrowed to a specific site, library, list or URL.</td>
<td></td>
</tr>
<tr>
<td>Restrict by tag</td>
<td>Results are limited to content tagged with specific terms, including site navigation terms.</td>
<td></td>
</tr>
<tr>
<td>Restrict by content type</td>
<td>Results are limited to a particular content type and all those that inherit from it.</td>
<td></td>
</tr>
<tr>
<td>Add additional filters</td>
<td>This uses syntax to create a custom query, adding additional filters and search terms.</td>
<td></td>
</tr>
<tr>
<td>Refiners</td>
<td>Choose your refiners</td>
<td>There is a comprehensive list of available attributes upon which the results set can be restricted by including mapped properties, document types and languages.</td>
</tr>
<tr>
<td>Settings</td>
<td>Query Rules</td>
<td>Administrators should query rules from Site Settings for this web part.</td>
</tr>
<tr>
<td>URL Rewriting</td>
<td>If the query is returning items from a catalog, administrators choose whether to use that catalog’s URL settings.</td>
<td></td>
</tr>
<tr>
<td>Loading behavior</td>
<td>Administrators choose whether this query is issued on the server while the page is loading, which is better for main content, or from the browser after the page appears.</td>
<td></td>
</tr>
<tr>
<td>Priority</td>
<td>Administrators choose the importance of this web part's query. Queries can be run according to their relative priorities when the search service is overloaded.</td>
<td></td>
</tr>
<tr>
<td>Test</td>
<td>Query text</td>
<td>Queries may give different results based on dynamic page-driven or user-driven values. The final query text can be seen based on the original query template, query rules and variable values.</td>
</tr>
</tbody>
</table>

6. After the configuration is complete, click **OK** to view the query results.

7. To stop editing click **Page tab > Save.**

Custom display templates are easy to create by site designers, because they are based upon an HTML file or JavaScript file and are stored in the Master Page Gallery within SharePoint.

### Media and Content

Web parts within the Media and Content category deal strictly with content that will be displayed on the page or media found within the site collection. For example, the Silverlight Web Part will allow a Silverlight application to be displayed within the SharePoint page. This section will cover the Media Web Part.
Media Web Part

The main function of the Media Web Part is to display and make available audio and videos that are available within SharePoint or stored on other site such as YouTube. These can be used to make available podcasts, educational videos, advertisements, etc. into the SharePoint page. Files embedded in SharePoint using the Media Web Part will utilize Silverlight to play the media.

Media is available in a variety of locations:

- Locally on the computer
- On SharePoint within an Asset Library
- From a web address such as a streaming media server
- As embedded code from another source site

1. Navigate to the page where the media web part should reside.

2. Click Edit from the global toolbar.

3. Click Insert > Media > Video and Audio.

   ![Inserting video and audio](image)

   If the file is From Computer, SharePoint will ask when uploading where the document should reside. Best practice is to save it in an Asset Library, since this library has the necessary metadata to handle these file types.

4. In this scenario, assume the media is already in a SharePoint Asset Library.

5. Navigate to the appropriate SharePoint site and library.

6. Select the audio or video file. Click Insert.

7. To stop editing, click Format Text > Save from the Edit group.

8. Click the Play button to enable the media content.
Lesson 4: Targeting Audiences with Content

SharePoint provides administrators with the ability to target content within a site to a particular audience. For example, a site or site collection administrator may wish to present a web part exclusively for managers on the home page of the site. Users, who are identified as managers, will see the web part; those who are not managers will not see that web part.

Another example of targeting would be using a web part that displays the current weather. If there are multiple offices, a weather web part can be added for each office. Each instance can be targeted to non-overlapping groups of users assigned on a per-office basis. Then, only the weather web part, for a user’s office location, will be displayed on the page; all others will be hidden.

Targeting is not limited to web parts. Lists, libraries and navigation links also have audience settings which may be used. However, audiences are not an adequate security mechanism. That is, audiences do not enforce security. They only serve to customize the presentation of the page and its contents. If a user has permissions to the content but it is not displayed on the page, they can still reach it by using the Site Contents link in the current navigation area.

Audiences can be defined as SharePoint groups, distribution lists or security groups found in Active Directory. To set up audience targeting, an individual must have at least Contributor permissions for the site. There is a three-step approach used to target an audience:

1. Enable audience targeting from the list or library.
2. Specify the target audience items.
3. Display the information in a web part.

Enable Audience Targeting from the Library or List

1. Navigate to the desired library and click Library or List > Library or List Settings from the Settings group > General Settings > Audience targeting settings.
**Audience targeting settings**

2. Check the **Enable audience targeting** checkbox and click **OK**.

*Enable audience targeting*

**Specify the Target Audience Items**

1. Navigate to the library or list.

2. Put a check next to the file you want to apply a target audience to. Choose **Edit Properties** from the document or item drop-down menu.

*Editing an item*

3. Add one or more audiences in the **Target Audience** field and click **Save**.
Viewing the Target Audiences field

Display Information in a Web Part

1. Navigate to the home page of the site and click Edit in the global toolbar.

2. Click the page and then click Insert > Web Part from the Parts group.

3. Choose Content Rollup > Content Query > Add.

Adding the Content Query Web Part

4. In the Content Query Web Part, choose Edit Web Part from the Edit drop-down menu to open the tool pane.

Editing the web part

5. In the tool pane, expand the Query section. Select the Show items from the following list option and then click the Browse button to select the library or list.

6. In the List Type section, verify that the Show items from this list type selection matches the type of data that is in the list or library.

7. In the Audience Targeting section, enable the appropriate options and click OK.
Apply audience targeting

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply audience filtering</td>
<td>This is necessary for the query to work properly.</td>
</tr>
<tr>
<td>Include items that are not targeted</td>
<td>This is optional.</td>
</tr>
</tbody>
</table>

8. Click **Format Text** > **Save** from the **Edit** group.

9. To test, log in as a member of the targeted group. The list of items in the Content Query Web Part should be seen only by members of the audience.

Lab 1: Adding and Configuring Web Parts

Learning Lake is looking to update the main intranet home page, making it more dynamic with recent announcements and the most popular documents used throughout the site. As a site owner, you need to build a dynamic page using out-of-the-box web parts. The page needs to pull announcements from all of the department sites as well as promote the most popular documents.

After completing this lab, you will be able to:

- Create custom content types for publishing
- Create a list template
- Create a managed property
- Use Content Search web parts

Estimated time to complete this lab: 60 minutes

**Exercise 1: Creating the Content Type**

Learning Lake is interested in rolling up all news items on the home page from all lower-lever sites. A custom Announcement content type must be created containing all of the columns needed to create announcements and render them using the Content Search web part.

1. Navigate to the **Learning Lake Intranet** home page.

2. Click **Settings** > **Site settings** > **Web Designer Galleries** > **Site content types**.

3. Click **Create**.

4. Created the content type as follows:
   a. **Name**: Type **Learning Lake Announcement**
b. **Description:** Type *Main announcement template for all items; includes a photo and teaser*

c. **Select parent content type from:** Select List Content Types

d. **Parent Content Type:** Select Announcement

e. **Existing Group:** Select Learning Lake

5. Click **OK**.

6. Click **Add from existing site columns**.

10. In the **Select columns from** drop-down, select **Page Layout Columns**.

11. In the **Available columns** section, locate **Page Image**.
12. Double-click to move it to the **Columns to Add**.

13. Keep **Yes** selected to update all lists inheriting this content type.

14. Click **OK**.

15. Click **Add from new site column**.

16. Create the column using the following:
   a. **Name**: Type **Summary**
   b. **Type**: Select **Multiple lines of text**
   c. **Existing Group**: Select **Learning Lake**
   d. **Additional column settings**: Leave the default values

17. Click **OK**.

18. Click **Column Order**.

19. Order the columns as follows:
   a. **Page Image**: Select 1
   b. **Title**: Select 2
   c. **Summary**: Select 3
   d. **Body**: Select 4
   e. **Expires**: Select 5

20. Click **OK**.

**Exercise 2: Applying the Content Type**
After creating the custom announcement, it must be set as the default item type on an Announcements list.

1. Navigate to the Human Resources Department site.

2. Click Settings > Add an app.

3. Locate the Announcements list template and click the icon.

4. Type HRAnnouncements and then click Create.

5. Click the HRAnnouncements link in the quick launch menu to navigate to the list.

6. On the ribbon, click List tab > Settings > List settings.

7. Click List name, description and navigation under General Settings.

8. Change the name to HR Announcements and click Save.

9. Click Advanced settings under General Settings.

10. Select Yes to Allow management of content types.

11. Scroll to the bottom and click OK.
12. From the List settings window, scroll to the Content Types section and click Add from existing site content types.

13. Select Learning Lake from the Select site content types from drop-down.

14. Double-click the Learning Lake Announcements to move it to the Content types to add column.

15. Click OK when complete.

16. From the HR Announcements settings window, scroll to the Content Types section and click Change new button order and default content type.

17. Make the Learning Lake Announcements content type number 1.

18. Clear the check box next to Announcements.

Exercise 3: Creating a List Template

Once a custom Announcements list has been created, it can be saved as a list template in order to speed up the creation of additional Announcements lists with similar configuration needs.

1. Under Permissions and Management, click Save this list as a template.
2. Complete the following for the **Save as a Template** dialog box:
   a. **File name**: Type *LearningLakeAnnouncement* (no spaces).
   b. **Template name**: Type *Learning Lake Announcement* (spaces).
   c. **Template description**: Type *Primary announcements template*
   d. Keep the checkbox cleared for **Include Content**.

3. Click **OK**.

4. On the **Operation Completed Successfully** window, click **OK** to return to the list settings page.

---

**Exercise 4: Adding Content to a List**

In this step, you will be creating announcements that will render on the home page of the site using the Content Search web part.

1. **Click HR Announcements** in the Page Title breadcrumb.

2. **Click new announcement** to add a new item to the list.

---
3. Click the link Click here to insert a picture from SharePoint.

4. Click Browse next to Selected Image box.

5. Click Site Collection Images in the left navigation pane.

6. Click the word add in the Click to add new item to upload a new photo to the images library.

7. Click Browse and locate the file Expense Report-small in C:\Labfiles\Media.

8. After locating the file, double-click to select the file.

9. Click OK.

10. In Title field, type Expense Report.

11. Click Save on the ribbon.
12. The newly added file should be listed in the Site Collection Images library.

13. Double-click the image to select it.

14. Click OK to insert the photo.

15. In the Title box, type **Monthly Expenses Submission Changes**.

16. In the Summary box, type **Learning Lake is changing the process for submitting monthly expenses.**

17. In the Body box, type **All monthly expenses must be reviewed and approved by your manager before being submitted to Finance. A new expense form is available on the Learning Lake portal to facilitate the process.**

18. In the **Expires** box, enter a date that is 30 days after the current date.

19. Click **Save** to add the announcement.

20. Click **new announcement** to create a second announcement.

21. Click the link **Click here to insert a picture from SharePoint**.

22. Click **Browse** next to Selected Image box.

23. Click **Site Collection Images** in the left navigation pane.

24. Click the word **add** in the **Click to add new item** to upload a new photo to the images library.

25. Click **Browse** and locate the file **Open Enrollment.png** in **C:\Labfiles\Media**.

26. After locating the file, double-click to select the file.

27. Click **OK**.

28. In **Title** field, type **Open Enrollment**.

29. Click **Save** on the ribbon.

30. The newly added file should be listed in the Site Collection Images library.

31. Double click the **Open Enrollment** image to select it.

32. Click **OK** to insert the photo.

33. In the **Title** box, type **Open Enrollment**.

34. In the **Summary** box, type **It’s that time of year to review and update your benefit elections.**

35. In the **Body** box, type **Open enrollment will last until the end of the month. Even if you are not changing your elections, please take the time to review your current coverage.**

36. In the **Expires** box, enter a date that is 30 days after the current date.

37. Click **Save** to add the HR Announcements library.
Exercise 5: Creating a Managed Property

Before adding the Content Search web part to the Learning Lake site, you need to create a managed property in the search schema. This is needed in order for the text that appears in the Summary field to appear in the Content Search web part.

1. Navigate to the Learning Lake Intranet top level site.

2. Click Settings > Site settings.

3. Click Site Collection Administration > Search Schema.

4. Search the Managed Property box for the existing property called RefinableString00. (Click green arrow to search)

5. Click RefinableString00 to view the properties.

6. Scroll to the Mappings to crawled properties (about two-thirds of the way down).

7. Click Add a Mapping.

8. In the Filter on a category drop-down, select SharePoint.
9. In the **Search for a crawled property name**, type `ows_s` to filter the list and click **Find**. The newly added SharePoint column `ows_Summary` should appear.

10. Select `ows_Summary` and click **OK**.

11. Scroll to the bottom of the page and click **OK**.

**Exercise 6: Adding the Content Search Web Part**

1. Navigate to the **Learning Lake Intranet** home page.

2. Click **Edit** in the global toolbar to place the page in edit mode.
3. Click in the left content region below Site Feed.

4. On the ribbon, click Insert > Web Part in the Parts section.

5. Click Content Rollup > Content Search > Add to insert the web part into the page.

6. Select the Content Search web part.

7. Click Edit Web Part on web part drop-down menu.

8. Click Change query in the Search Criteria section in the web part properties panel.

9. Select Items matching a content type (System) in the Select a query section.

10. Select Current site collection in the Restrict by app section.

11. Leave the option Don't restrict by any tag selected.

12. Select the Learning Lake Announcement content type in the Restrict by content type section. If you do not see the content type, select the option Show all content types in the content type drop-down and then select Learning Lake Announcement.
13. Click OK to save the query results.

14. Back in the Content Search web part properties, look under the Display Templates section and select the **List** control template.

15. Under Item select **Picture on left, 3 lines on right**.

16. Confirm the box is checked next to **Don’t show anything when there are no results**.

17. Expand the **Property Mappings** section.

18. Click the box next to **Change the mapping of managed properties for the fields in the Item Display template**.


20. Change the option in Line 2 to the **RefinableString00**.

21. Click **OK** to save the web part settings.

22. On the ribbon, click **Format Text > Edit > Save** to save the page.

23. After a search crawl completes in a few minutes, the web part will update with the contents.
Lab 2: Connecting Web Parts

Learning Lake is interested in creating a dashboard style page that summarizes all of the open issues and tasks for projects related to a SharePoint 2016 deployment. Creating a new web part page that contains connected web parts will allow members of a project to filter all tasks and issues by project without having to navigate to a variety of lists.

After completing this lab, you will be able to:

- Place web parts on a page
- Connect web parts on a page to pass filters between them

Estimated time to complete this lab: 30 minutes

Exercise 1: Creating a Project Site

1. Navigate to the Learning Lake Intranet home page.
2. Click Settings > Site contents.
3. Click new subsite in the Subsites section.
4. Type Learning Lake Projects as the name of the site.
5. Type projects as the URL.
6. Select Project Site as the site template.
7. In the Navigation Inheritance section, select Yes for Use the top link bar from the parent site.
8. Click Create. (This may take a moment to complete.)
Exercise 2: Creating an Issue Tracking List

Now that you have configured site you need to create an issues list.

1. In the Learning Lake Projects site, click **Settings > Add an app**.

2. Click the template **Issue Tracking**.

3. Type **Issues** and click **Create**.

4. On the current navigation, click **Issues**.

5. On the ribbon, click **List > Settings > List Settings**.

6. Under the Columns section, click **Category** to view the column properties.

7. Replace the choice options with the following choices on separate lines; text only.
   a. Type **Infrastructure Planning**
   b. Type **Upgrade**
   c. Type **Testing**

8. In the **Default value** box, erase the value to leave it blank.

9. Click **OK** to update the column.

10. On the quick launch bar, click **Tasks**.

11. On the ribbon, click **List > Create Column** from the **Manage Views** section.

12. Type **Category** as the name of the column.

13. Select **Choice (menu to choose from)** as the column type.

14. Replace the choice options with the following choices on separate lines; text only.
   a. **Infrastructure Planning**
   b. **Upgrade**
c. Testing

15. In the Default value box, erase the value to leave it blank.

16. Click OK to add the column to the task list.

Exercise 3: Updating the Home Page

Now that you have built the underlying lists, you will then need to customize the home page to aggregate the information from the lists.

1. Click Home in the quick launch to navigate to the Learning Lake Projects home page.

2. On the ribbon, click Page > Edit Page from the Edit group.

3. Click the link Remove This on the Get started with your site web part.

4. Click the web part menu on the Site Feed web part. (The web part menu appears when you hover the title bar of the web part. A small triangle will appear to the right.)

5. Click Delete.

6. On the pop-up window, click OK to confirm.

7. Click the web part menu on the Documents web part.

8. Select the option to delete the web part.

9. On the pop-up window, click OK.

10. In the right web part zone, click Add a web part.

11. Select the Issues list from the Parts area and click Add.
12. Within the **Issues** web part, click the View menu (the ellipsis ...) and select **Modify this View**.

![](Issues.png)

In order for connected web parts to work the fields you wish to create the connection on must be visible in the view within the web part.

13. Check the box next to **Category**.

14. Change the **Position from Left** to be **1** for **Category**.

15. Uncheck the box next to **Priority**.

16. Click **OK** to update the view.

17. On the ribbon, click **Page > Edit Page** from the **Edit** group.

18. Click the **Issues Web Part** menu and select **Edit Web Part**.

19. In the **Issues** properties panel, expand the **Miscellaneous** section.

20. Check the box next to **Server Render**, then click **OK** to save and close the web part properties panel.

![](ServerRender.png)

Client-side rendering is preferred for most applications, in order to offload processing from the servers. In some cases, server-side rendering is helpful. Here, it is used in order for the display to refresh properly.
21. Click **Add a web part** in the left web part zone.

22. Select the **Tasks** list and click **Add**.

23. Within the **Tasks** web part, click the view menu (the ellipsis "…") and select **Modify the view**.

24. Check the box next to **Category**.

25. Change the **Position from Left** to be 1 for **Category**.

26. Click **OK** to update the view.

27. On the ribbon, click **Page > Edit Page** from the **Edit** group.

28. On the **Issues** web part, click the web part edit menu and select **Connections > Get Filter Values From > Tasks**.

29. In the **Provider Field name**, select **Category**.

30. In the **Consumer Field Name** drop-down, select **Category**.

31. Click **Finish**.

32. Click the **Tasks** web part menu and select **Edit Web Part**.

33. In the **Tasks** properties panel, expand the **Miscellaneous** section.

34. Check the box next to **Server Render** and click **OK** to save and close the web part properties panel.

35. On the ribbon, click the **Page > Stop Editing**.
Exercise 4: Testing the Home Page

Now that you have configured the lists and web parts, you can test out the functionality.

1. Below the Tasks list, click Add new item and type Hardware Procurement as the task name.
2. Click Show More to view the remaining task fields.
3. Select Infrastructure Planning as the Category and click Save.
4. Below the Tasks list click Add new item and type Database Attachment as the task name.
5. Click Show More to view the remaining task fields.
6. Select Upgrade as the Category and click Save.
7. Below the Issues list, click Add new item.
8. Type Server Installation as the Title.
9. Select Infrastructure Planning as the Category and click Save.
10. Below the Issues list, click Add new item.
11. Type Error in Database as the Title.
12. Select Upgrade as the Category and click Save.
13. Below the Issues list, click Add new item.
14. Type Install SharePoint as the Title.
15. Select Infrastructure Planning as the Category and click Save.
16. Below the Issues list, click Add new item.
17. Type Get pricing for licenses as the Title.
18. Select Upgrade as the Category and click Save.
19. A new icon (a double-ended arrow) appears in the Tasks web part in a column called Select. This indicates that the value from the selected row will be sent to another web part as either a parameter or a filter.
20. Click the arrow next to Infrastructure Planning or Upgrade. Notice the Issues list filters to only show the issues with the matching category. Click the other arrow and watch the Issues list refresh.

Lab 3: Applying Themes to Your Company Portal
Learning Lake is interested in changing the company portal to match the company colors as well as have the company logo. As a site administrator, you will change the look of the main Learning Lake site to meet the needs.

After completing this lab, you will be able to:

- Customize and apply a theme to your portal
- Add a logo to your portal

Estimated time to complete this lab: 15 minutes

Exercise 1: Adjusting the Theme


2. Click Settings > Site settings > Look and Feel > Change the look.

3. The design gallery opens with a variety of predefined layouts.

4. Click the Breeze template towards the bottom of the page.

5. On the left side of the window, click Remove under the background photo.
6. On the pop-up window, click OK to confirm.

7. Click the Colors drop-down and scroll through the list of predefined colors until you find the following palette:

8. Keep the site layout set to Seattle.

9. Click Fonts and select Georgia Segoe UI.

10. Click Try it out. It might take a moment to render.
11. A preview of the updated theme renders with the option to keep the look or make adjustments. Click Yes, keep it.

Exercise 2: Changing the Logo

1. Navigate to Site Settings > Look and Feel > Title, description and logo.

2. In the Logo and Description section click From Computer to locate an image.

3. Click Browse and navigate to C:\Labfiles\Media.

4. Double-click LearningLake_Logo.png and click OK to add the logo to the site.

You may see a banner warning Image not found! If you do, ignore the error. It may be that the file has already been uploaded.

5. Click OK on the page to finalize saving the logo to the site. You should see the logo immediately in the top left corner.

6. Navigate to the Learning Lake Intranet site.