MODULE 2 Creating a Company Portal

Contents

MODULE OVERVIEW

LESSON 1: CREATING A SITE STRUCTURE

LESSON 2: DEFINING SHAREPOINT APPS

LESSON 3: ADDING ADDITIONAL INFORMATION TO DOCUMENT LIBRARY/LIST SETTINGS

LESSON 4: EXPLAINING VIEWS ON LISTS AND LIBRARIES

LESSON 5: CREATING VIEWS IN LISTS AND LIBRARIES

LESSON 6: MODIFYING NAVIGATION

LAB 1: CREATING A STRUCTURED COMPANY PORTAL

LAB 2: CREATING A LIST USING SHAREPOINT DESIGNER (OPTIONAL)

Module Overview

This module explains to site collection administrators how to create sites, document libraries and lists, as well as manage navigation. The first major milestone, after planning the company portal, is executing and building the site structure. The site structure includes the components for storing and presenting information namely sites, lists and libraries and apps, which are new to SharePoint 2016. Site structure provides the framework for the entire portal.

After completing this module, students will be able to:

• Implement a site structure

• Add and customize apps

• Create and customize views

• Modify site navigation

Lesson 1: Creating a Site Structure

It all starts with the site or subsite. The distinction between a site and a subsite is that a subsite is any site created hierarchically below the top level site in a site collection. The term site may refer to either the top level site or a subsite.

The site structure is the framework for the site collection. It provides the shape and place for users to locate data containers. A properly-designed site structure is intuitive for users and easy to manage and secure. Users will find the site structure requires little effort and is an easy piece with which to work when built properly.

When users want to create a subsite, they can choose from a list of available templates. Templates can include Project Sites, Business Intelligence Sites, Team Sites, Community Sites and more. The version of SharePoint purchased (Standard, Enterprise, or SharePoint Online) will determine template availability. A template comes
pre-built with certain features enabled, apps configured and pages created. This standardized starting point is meant to save time versus having to configure a site from scratch.

After users create a subsite, they can add more apps to extend the functionality of their site, and then add content (items) to their apps. The number of apps they create should be limited to their organizations’ ability to manage them. If too many apps are configured, it makes it hard to manage permissions and users struggle to find content. If too many apps are created, users could sacrifice flexibility. Administrators should be sure to talk to stakeholders to determine what fits best in the organization.

There are multiple ways to create a subsite. One method is to use the Manage Content and Structure feature from the Site Settings area. Another method is to begin from the Site Contents page within a site collection. In order to be able to create subsites, users will need to be in the Site Collection Administrators group, Site Owners group or have the specific permissions to create sites.

Creating a Subsite

1. Click the **Settings** menu (gear wheel) in the top right corner.
2. Click **Site contents**.

   ![Accessing site contents](image)

3. Under the **Subsites** heading, towards the bottom of the page, click **new subsite**.

   ![New subsite button](image)

4. Type the name of the site in the **Title** box.
5. Type the desired URL in the **Web Site Address** box.

   **URLs should not have any special characters or spaces. A recommendation is to use proper case (a mix of uppercase and lowercase) if the URL must contain more than one word. Shorter URLs are preferred; the site can be re-titled later.**
6. Click the desired template.

The list of templates available may vary based upon the ones made available or the features enabled within the site collection.

7. Choose the appropriate permission option based on the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use same permissions as parent site</td>
<td>This gives permission to access the new site to the same users who have access to this parent site. It means permissions are shared between both parent and child sites.</td>
</tr>
<tr>
<td>Use unique permissions</td>
<td>This creates a new set of permissions for this site and adds an extra step to the site creation process.</td>
</tr>
</tbody>
</table>

8. Choose the behavior of the navigation based on the following decision: **Use the top link bar from the parent site?**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>This adds the same navigational links as the parent site. Administration of the navigation is done from the parent site.</td>
</tr>
<tr>
<td>No</td>
<td>Navigational elements are added to the top navigation for the current site only. Administration of the navigation is done from the current site navigation settings.</td>
</tr>
</tbody>
</table>

There will be additional information on modifying the navigation later in this module.
Creating a Team Site

Lesson 2: Defining SharePoint Apps

A SharePoint app is a small, easy-to-use application that solves a specific end user or business need such as storing content or aggregating and displaying data. Examples of apps are document libraries, lists, calendars, surveys and weather information. Apps are designed to be easy for users to add, use, manage, upgrade and remove without involvement from a technical support team.

Apps can vary from basic document libraries and lists to custom developed solutions that can be downloaded and installed from a company app store or the Microsoft Store. App stores are designed to host SharePoint apps that can be safely downloaded and installed.

A SharePoint app may contain several different components that are created automatically when the app is installed. Because apps are a self-contained functionality that is deployed to a specific site within SharePoint, site owners have the ability to install or remove the app without disruption to the existing SharePoint environment.

When installing apps from a company store or the Microsoft Store, the app requests the permissions that it needs during installation from the user who is installing it. These permissions are defined in the app manifest file by the app developer. An app is granted permissions by the user, who is adding the app. Users can grant only the permissions that they have at the time of the installation.
### Types of Apps

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access App</td>
<td>Used to create a connection to an Access database created in Office 2016.</td>
</tr>
<tr>
<td>Announcements</td>
<td>Used to display news items, statuses and other bits of information.</td>
</tr>
<tr>
<td>Asset Library</td>
<td>Used to share, browse and manage rich media assets like images, audio and</td>
</tr>
<tr>
<td></td>
<td>video files.</td>
</tr>
<tr>
<td>Calendar</td>
<td>It’s a shared calendar that displays upcoming meetings or events and can</td>
</tr>
<tr>
<td></td>
<td>be synchronized with Microsoft Outlook.</td>
</tr>
<tr>
<td>Contacts List</td>
<td>These shared contacts for a team can be synchronized with Microsoft</td>
</tr>
<tr>
<td></td>
<td>Outlook.</td>
</tr>
<tr>
<td>Custom List</td>
<td>It’s a blank list which can be customized with columns and views.</td>
</tr>
<tr>
<td>Custom List in Datasheet View</td>
<td>It’s a blank list displayed in a spreadsheet style which makes adding</td>
</tr>
<tr>
<td></td>
<td>information much easier. (Note: This will need an ActiveX control which is</td>
</tr>
<tr>
<td></td>
<td>a part of Microsoft Office.)</td>
</tr>
<tr>
<td>Data Connection Library</td>
<td>Contains ODC, UDC and PerformancePoint data connections.</td>
</tr>
<tr>
<td>Discussion Board</td>
<td>It’s for newsgroup-style discussions; it’s easy to manage and requires</td>
</tr>
<tr>
<td></td>
<td>approvals for posts.</td>
</tr>
<tr>
<td>Document Library</td>
<td>Used to store documents and other files that are needed to be shared.</td>
</tr>
<tr>
<td>External List</td>
<td>Used to create a view of external content type.</td>
</tr>
<tr>
<td>Form Library</td>
<td>Used to manage business forms and requires an XML editor like Microsoft</td>
</tr>
<tr>
<td></td>
<td>InfoPath.</td>
</tr>
<tr>
<td>Import Spreadsheet</td>
<td>Used to import Microsoft Excel spreadsheets into SharePoint.</td>
</tr>
<tr>
<td>Issue Tracking</td>
<td>Used to help track issues with a project or a task. (Issues can be assigned</td>
</tr>
<tr>
<td></td>
<td>a priority and status.)</td>
</tr>
<tr>
<td>Links</td>
<td>Used to create and display web pages or other resources.</td>
</tr>
<tr>
<td>Picture Library</td>
<td>Used to upload and share pictures.</td>
</tr>
<tr>
<td>Promoted Links</td>
<td>Used to display a set of link actions in a tile based visual layout.</td>
</tr>
<tr>
<td>Report Library</td>
<td>Used to create and manage web pages and documents for tracking metrics,</td>
</tr>
<tr>
<td></td>
<td>goals and business intelligence information.</td>
</tr>
<tr>
<td>Survey</td>
<td>Used to deliver a set of questions people need to answer and then display</td>
</tr>
<tr>
<td></td>
<td>them in a graphic summary.</td>
</tr>
<tr>
<td>Tasks</td>
<td>Used to keep track of shared or personal tasks.</td>
</tr>
<tr>
<td>Wiki Page Library</td>
<td>It’s an interconnected set of web pages which can contain text, images and</td>
</tr>
<tr>
<td></td>
<td>web parts.</td>
</tr>
</tbody>
</table>

### Adding an App

Both libraries and lists are apps within SharePoint, and can easily be added by site administrators in order to build the necessary structure to support collaboration or content sharing.

1. **Click Settings** (gear wheel).

2. **Click Add an app.**
Adding an app

3. Click **App Details** to open a new page containing a description of the app and a link to add it to the site.

4. Alternatively, click the app icon to open the dialog box.

5. Enter a name for the app in the **Name** box.

   - **Tip:** The name that users supply for the app will be used as the URL for the app. To keep the URL simple, they should limit the app name to alphanumeric characters. They will be able to later retitle the app with a more visually friendly name.

6. Click **Create** to add the app to the site.

Adding a calendar

The **Advanced Options** link gives site administrations additional configuration options such as the ability to choose whether it appears in the left navigation or if a new version should be created when new files are added to a library.

**Accessing the SharePoint Store**

The SharePoint Store is Microsoft's public forum where site collection administrators and site owners can purchase and download apps directly from third-party developers. These apps can be deployed for personal or organizational use directly from within the SharePoint site.
Apps that create a set of lists and libraries upon deployment require the person, deploying the app, to have the Manage Hierarchy or higher permission level within the site where the app is deployed.

If the site has been configured to allow access to the public Microsoft SharePoint Store, users may access it from the Add an App page from within their site.

1. Click **Settings**.

2. Click **Add an app**.

3. Click **SharePoint Store** from the left navigation.

4. Browse the Microsoft Store to locate the app to download and install.
The SharePoint Store

5. Click the app name to view details and reviews.
6. Click Add It to proceed with the installation process.
7. When prompted, enter a valid Microsoft Live ID and password.

8. Click Continue to confirm the addition of the app to the site.

9. Once the app has been downloaded, it will become available within the SharePoint site from where it was acquired by clicking Settings > Add an app.

10. Click the app name under the Apps you can add section.
Lesson 3: Adding Additional Information to Document Library/List Settings

Additional information beyond the contents of a document or list item is often referred to as metadata, or information about information. Within SharePoint, columns are the tool in which this additional information is stored. Site administrators have the ability to create custom columns for use across multiple lists, or as sources of information for look-ups within other lists.

There are two levels at which columns can be defined: lists/library or site. The first level that custom columns can be defined is at the individual list/library level. This allows for greater flexibility and independence in storing the information. The drawback is that list columns do not lend themselves to easy cooperation across lists and libraries.

The second level is at the site level. Site columns can be defined in a central site column gallery, and are available to add to lists and libraries throughout the site and its subsites. This approach requires some additional planning, but allows for better relationships across multiple lists. By using the same site column definition in multiple lists and libraries, searching for items with a specific property value is easier because the column name is identical across lists. Moreover, with choice columns, the site column approach allows administrators to maintain and update the choices from a single location instead of having to update each instance of the column individually.

When adding a column to a list or library, the new column will appear at the bottom of the default input form. Also, new columns appear on the default view of the list or library unless the checkbox is cleared. Depending on what is
desired, site administrators will need to account for these default behaviors.

**List or Library Level Column**

1. Navigate to the list or library of choice and click **Library or List > Create Column** from the **Manage Views** group.

   ![Create Column](image)

   **Create a new library column**

2. From the **Create Column** window, provide the name of the column, identify the desired attributes and then click **OK**.

   ![Create Column Window](image)

   **Configure new library column**

   Notice that the column is immediately added to the default view and is located on the right-hand side.
Adding a Site Level Column

1. Navigate to the list or library of choice, and click Library or List > Library or List Settings from the Settings group.

2. If necessary, scroll down and select Add from existing site columns found under the Columns section.

<table>
<thead>
<tr>
<th>Column</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Single line of text</td>
</tr>
<tr>
<td>Scheduling Start Date</td>
<td>Publishing Schedule Start Date</td>
</tr>
<tr>
<td>Scheduling End Date</td>
<td>Publishing Schedule End Date</td>
</tr>
<tr>
<td>Created</td>
<td>Date and Time</td>
</tr>
<tr>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>Created By</td>
<td>Person or Group</td>
</tr>
<tr>
<td>Modified By</td>
<td>Person or Group</td>
</tr>
<tr>
<td>Checked Out To</td>
<td>Person or Group</td>
</tr>
</tbody>
</table>

Available library columns

3. Choose the column(s), from the list provided, and click Add to the Columns to add text box.

4. In the Options section, choose if the column(s) should be added to the default view for the list or library.

   ![The Column ordering option changes the order in which they are presented on the default forms. It does not control the order of the columns in the list view. That is controlled by modifying the view of a list or library.](image)

Lesson 4: Explaining Views on Lists and Libraries

Looking for and exposing data in SharePoint 2016 comes down to two basic elements: Searching and Views. Views are commonly overlooked by users who are becoming familiar with SharePoint 2016. Views are often thought of as being one-dimensional, when in fact they are a major component for improving the effectiveness of app parts. Using views, users can create general purpose views of lists and libraries, or views can be created for specific...
purposes. When combining views and app parts, views can be tailored even further to a specific subset of people by using audience targeting.

App parts are used to display content for lists or libraries created within a site. Web parts are placeholders for several different pieces of content or functionality.

Simply defined, views are a presentation of data from the underlying list or library. Views can limit how much data is presented at one time through filters, thresholds or column selections. They can arrange the data through sort order and grouping settings. Views can also format the data to be presented using different visual layouts to match the needs of the users consuming the data.

Types of Views

SharePoint provides four basic types of views: Standard, Datasheet, Calendar and Gantt. Each view provides a unique way of displaying information from a traditional editable style spreadsheet to a management style timescale project. View options, available in SharePoint 2016, are listed in the following table:

<table>
<thead>
<tr>
<th>View Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard</td>
<td>View data on a web page. Choose from a list of display styles.</td>
</tr>
<tr>
<td>Calendar View</td>
<td>View data as daily, weekly or monthly.</td>
</tr>
<tr>
<td>Datasheet View</td>
<td>View data in an editable spreadsheet format that is convenient for bulk editing and quick customization.</td>
</tr>
<tr>
<td>Gantt View</td>
<td>View list items in a Gantt chart to see a graphical representation of how a team's tasks relate over time.</td>
</tr>
<tr>
<td>Custom View in SharePoint Designer</td>
<td>Start SharePoint Designer to create a new view for this list with capabilities such as conditional formatting.</td>
</tr>
</tbody>
</table>

Use of Columns and Metadata for Views

Each view, which is created or modified, uses columns to display the metadata. Columns are the core elements of views. Columns are what allow different types of sorting, grouping, filtering and searching. With that in mind, it is crucial that site administrators think of the big picture when creating and adding columns to a list or library. They should first check to see whether the column is available as a site column before creating a new column for a list or library. This helps maintain consistency and helps to prevent redundancies.

Accessing Views

Within SharePoint 2016, the ability to access, create or modify different views is done using the View drop-down menu. This menu is the ellipse that is directly to the left of the search box.
Lesson 5: Creating Views in Lists and Libraries

When creating views, it is important that site administrators keep the audience in mind. A view that will be used by many different people needs to be a public view. If it will be used only by its creator, then it can be set up as a personal view. Views provide a customized experience, so that users see only the data that pertains to them. Site administrators will also need to consider the amount of information that will be exposed in the view. For a large amount of information, it might be necessary to adjust the number of items per page settings. This can be done using filters, grouping or limiting the number of items to be displayed which will not hurt performance within SharePoint 2016.

Creating a View: Method 1

1. Navigate to the desired list or library.

2. Using the view menu choose Create View from the View drop-down menu.

3. Select the desired View Type.

Creating a View: Method 2

1. Navigate to the desired list or library.

2. Using the view menu choose Create View from the View drop-down menu.

3. Click Library or List > Create View from the Manage Views group.
Creating a view from the ribbon

4. Select the desired View Type.

![SharePoint ribbon showing Create View option]

Choosing a view type

Based on the view type selected, additional options to customize the view will be presented. The following sections highlight the different configuration options for each view type.

**Standard View Options**

The Standard view is a list of the metadata for the items in the list or library. This view, along with all other views, is completely dependent upon what metadata is displayed and how it is sorted, filtered or grouped. Following is a list of the options for the Standard view.

<table>
<thead>
<tr>
<th>View Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Name/Make this the default view</td>
<td>When creating the view, administrators should keep the name simple as it will appear in the URL. After the view is created, they can modify the view and update the view name to include spaces and special characters for display purposes.</td>
</tr>
<tr>
<td>Audience</td>
<td>This option refers to either a public view or personal view. Personal views can be created by SharePoint users that only they can see. Public views are created for anyone using that SharePoint site.</td>
</tr>
<tr>
<td>Columns</td>
<td>Administrators select which columns to display and their relative position from the left column.</td>
</tr>
<tr>
<td>Sort</td>
<td>This option defines the order in which items are sorted as they are displayed in the view. To define more than two levels of sorting, administrators can define a custom view in SharePoint Designer.</td>
</tr>
<tr>
<td>Filter</td>
<td>The default filter is Show all items in this view or it can be customized. Ten custom filters can be applied to the columns with comparison operators and or.</td>
</tr>
<tr>
<td>Tabular View</td>
<td>This adds the functionality to select multiple items to do bulk operations. This is on by default in SharePoint 2016.</td>
</tr>
</tbody>
</table>
### View Option | Description
--- | ---
**Group By** | Administrators select up to two columns for grouping items in the display.

**Totals** | Depending upon the column type, some or all of the following options will be available: Count, Average, Maximum, Minimum, Sum, Standard Deviation or Variance.

**Style** | This option is used to select a formatting display for the view: Basic Table, Document Details, Newsletter, No lines, Shaded, Preview Pane or Default.

**Folders** | If folders are being used, this option chooses whether to display items in their respective folders, or without folders in a single, flat list. Administrators can choose all folders, top level folders or only those within a specific content type based on the folder parent or document set.

**Item Limit** | Items can be displayed in batches or the total number can be limited to a specific amount.

**Mobile** | Used to create a view for mobile devices. Options include: make it default, select the number of items per page, and field to display in mobile list simple view.

---

**A note about Personal and Public Views:** These two different views are available depending upon permissions. Any user can create a personal view, but only SharePoint site owners have the ability to create a public view.

**One recommendation is to make the Style setting Shaded to help with readability. Another recommendation is to consider item limits and how they relate to speed. Depending on the user’s connection, too many items available in a view can negatively impact performance.**

**When creating new views, if administrators do not start from the default All Documents/All Items view, the View menu and Search box are removed. They must choose to start from the initial default view that is created when the list or library is created.**

### Standard View with Expanded Recurring Events

This additional view on calendar-based lists renders data on a web page in a list format. However, it will also render each instance of a recurring event. Site administrators can choose from a list of display styles.

### View Option | Description
--- | ---
**View Name/Make this the default view** | When creating the view, administrators should keep the name simple as it will appear in the URL. After the view is created, they can modify the view and update the View name to include spaces and special characters for display purposes. When creating a Public view, it is possible to make this the default view.

**Audience** | This refers to either a Public view or Personal view. Personal views can be created by SharePoint users that only they can see. Public views are created for anyone using that SharePoint site.

**Columns** | Administrators select which columns to display and their relative position from the left column.

**Sort** | This option defines the order in which items are sorted as they are displayed in the view. To define more than two levels of sorting, administrators can define a custom view in SharePoint Designer.

**Filter** | The default filter is *Show all items in this view* or it can be customized. Ten custom filters can be applied to the columns with comparison operators “and” and “or.”
### Calendar View

The Calendar view is an easy way to display time-based data in a more traditional calendar format. It allows easy, at-a-glance access to events and items without having to scroll through a long list of data. The following table describes the options and descriptions for a Calendar view.

<table>
<thead>
<tr>
<th>View Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View Name</strong></td>
<td>When creating the view, administrators should keep the name simple as it will appear in the URL. After the view is created, they can modify the view and update the View name to include spaces and special characters for display purposes. When creating a Public view, it is possible to make this the default view.</td>
</tr>
<tr>
<td><strong>Audience</strong></td>
<td>This refers to either a Public view or Personal view. Personal views can be created by SharePoint users and they only see this view. Public views are created for anyone using that SharePoint site.</td>
</tr>
<tr>
<td><strong>Time Interval</strong></td>
<td>This selects the columns which identify the start time and end time for each event.</td>
</tr>
<tr>
<td><strong>Calendar Columns</strong></td>
<td>This identifies the columns which contain the text for each event to be displayed on the calendar. Selections include Month View Title, Week View Title, Week View Sub Heading, Day View Title and Day View Sub Heading.</td>
</tr>
<tr>
<td><strong>Default Scope</strong></td>
<td>This determines the default scope used to display the calendar when the view is opened. Scopes include Day, Week or Month.</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td>The default filter is <em>Show all items in this view</em> or can be customized. Ten custom filters can be applied to the columns with comparison operators “and” and “or”.</td>
</tr>
<tr>
<td><strong>Mobile</strong></td>
<td>Mobile is used to create a view for mobile devices. Options include: make it default, select the number of items per page, and field to display in mobile list simple view.</td>
</tr>
</tbody>
</table>

### Datasheet View

The Datasheet view is useful for updating and maintaining lists and metadata. It uses many of the same features that are found in an Excel spreadsheet: Autofill, sorting, filtering and quick navigation from cell to cell or record to record. The options and descriptions for a Datasheet view are included in the following table.

<table>
<thead>
<tr>
<th>View Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View Name</strong></td>
<td>When creating the view, it is good to keep the name simple as it will appear in the URL. After the view is created, administrators can modify the view and update the View name to include spaces and special characters for display purposes. When creating a Public view, it is possible to make this the default view.</td>
</tr>
<tr>
<td><strong>Audience</strong></td>
<td>This refers to either a Public view or Personal view. Personal views can be created by SharePoint users and they only see this view. Public views are created for anyone using that SharePoint site.</td>
</tr>
<tr>
<td>View Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Columns</td>
<td>Users can select the columns and position from the Left column in the view.</td>
</tr>
<tr>
<td>Sort</td>
<td>A two-level sort can be applied to a view.</td>
</tr>
<tr>
<td>Filter</td>
<td>The default filter is Show all items in this view or can be customized. Ten custom filters can be applied to the columns with comparison operators “and” and “or”.</td>
</tr>
<tr>
<td>Totals</td>
<td>Depending upon the column type, some or all of the following options will be available: Count, Average, Maximum, Minimum, Sum, Standard Deviation or Variance.</td>
</tr>
<tr>
<td>Folders</td>
<td>If folders are being used, this option determines whether to display items in their respective folders, or without folders in a single, flat list. Administrators can choose all folders, top level folders or only those within a specific content type based on the folder parent or document set.</td>
</tr>
<tr>
<td>Item Limit</td>
<td>Item Limit displays items in batches or limits the total number to a specific amount.</td>
</tr>
</tbody>
</table>

**Gantt View**

Gantt views provide the ability to see a timeline of events that mirror Microsoft Project or other scheduling software. This view produces a Gantt chart based on the information stored in each item. This provides a convenient way to view task lists, to see whether they overlap, and to visualize tasks within a broader timeline. Creating a Gantt view is similar to creating a Standard view, with the exception of selecting the Gantt columns. The following table lists the options and descriptions for a Gantt view.

<table>
<thead>
<tr>
<th>View Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Name/Make this the default view</td>
<td>When creating the view, it is good to keep the name simple as it will appear in the URL. After the view is created, users can modify the view and update the view name to include spaces and special characters for display purposes.</td>
</tr>
<tr>
<td>Audience</td>
<td>This refers to either a Public view or Personal view. Personal views can be created by SharePoint users and they only see this view. Public views are created for anyone using that SharePoint site.</td>
</tr>
<tr>
<td>Columns</td>
<td>Users select the columns and the position from the Left column that appears in the view.</td>
</tr>
<tr>
<td>Gantt Columns</td>
<td>Users specify columns to be represented in the Gantt chart. Start Date and Due Date are required date fields.</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort can apply two-level sorts to a view.</td>
</tr>
<tr>
<td>Filter</td>
<td>The default filter is Show all items in this view. Ten custom filters can be applied to the columns with comparison operators “and” and “or”.</td>
</tr>
<tr>
<td>Group By</td>
<td>Users select up to two columns for a group or subgroup of displayed items.</td>
</tr>
<tr>
<td>Totals</td>
<td>Depending upon the column type, some or all of the following options will be available: Count, Average, Maximum, Minimum, Sum, Standard Deviation or Variance.</td>
</tr>
<tr>
<td>Style</td>
<td>Users select a formatting display for the view: Basic Table, Document Details, Newsletter, No lines, Shaded, Preview Pane or Default.</td>
</tr>
<tr>
<td>Folders</td>
<td>If folders are being used, this option will determine whether to display items in their respective folders, or without folders in a single, flat list. Administrators can choose all folders, top level folders or only those within a specific content type based on the folder parent or document set.</td>
</tr>
<tr>
<td>Item Limit</td>
<td>Item Limit displays items in batches or limits the total number to a specific amount.</td>
</tr>
</tbody>
</table>

**Custom View in SharePoint Designer**

This option is beyond the scope of this course. However, all of the features shown here are available within SharePoint Designer 2013. SharePoint Designer 2013 also has the ability to add conditional formatting to a view that allows the information to be displayed differently per view.

The examples below show a SharePoint library with the Rating column and Number of Likes column. A conditional format that highlights any document with a rating of four or greater will highlight the row.
Lesson 6: Modifying Navigation

Navigation elements are essential to the usability of a SharePoint site. When administrators provide links for users to navigate between sites, subsites and apps, this enhances the usability of the site. There are two major navigation elements available in SharePoint: global and current navigation.

Global Navigation: Also known as the top link bar, global navigation is the set of links displayed near the top of the screen. Global navigation is so named because it can be inherited by subsites; thereby, allowing administrators to provide a consistent experience throughout the site collection. The primary challenge in managing the global navigation is to balance the number of links with the amount of space they take up. It needs to be useful, but not crowded, at the top.

Current Navigation: Also known as the quick launch, current navigation is the set of links usually displayed down the left side of the screen. Current navigation is so named because each site and subsite has its own set of links to display in this area. One of the challenges in managing the current navigation area is that as a new app is added to the site, the default behavior is to add a new link in the current navigation for the new app. After a while, the current navigation becomes cluttered and a difficult area with which to work. Administrators will need to manage and customize this area to provide the optimal number of links for the most frequently-requested content for their users.

Both global navigation and current navigation can be presented using different methods: structural and metadata-driven navigation.

Structural Navigation: This is the more familiar approach, where a static list of links is provided for the users to access different elements.
**Metadata-Driven Navigation:** This approach uses the Managed Metadata Service to present dynamically-built categories based on Term Sets and Search results. This approach will be explored further in an upcoming module.

**Removing an Item from the Structural Navigation**

Depending upon the type of content, certain items can be deleted from the navigation while others can only be hidden. Items that can be deleted have an X next to the name, whereas links that can only be hidden have the icon.

1. Navigate to the site where the changes are to be made.
2. Click **Edit Links**.
3. Click the X next to the item to be removed.
4. For items that can be hidden, click the icon.
5. Click **Save** to finalize the changes and switch out of edit mode.

**Edit mode**

Items that are hidden are not removed from the navigation, they are simply greyed...
out and stylized with italic text and a new icon. If administrators remove a heading, it will also remove all of
the subordinate links that appear below it. A dialog window appears confirming the choice to delete the
heading and subordinate links.

Adding Links to the Navigation

1. Browse to the site requiring navigation changes.
2. Click Edit Links.
3. Click + link.
4. Enter text in the Text to display box.
5. Enter the full URL in the Address.
6. Click OK.
7. Click Save to switch out of edit mode.

OR

1. Navigate to the library or list containing the content to add to the navigation.
2. Click Edit Links.
3. Click and drag the item to the left navigation panel within the browser.
4. Release the mouse to drop or add the item to the navigation.
5. Click Save to switch out of edit mode.

Sorting the Navigation

1. Navigate to the site where the changes are to be made.
2. Click Edit Links.
3. Click and drag the item in the navigation to change the order.
4. Click Save to switch out of edit mode.

Internet Explorer and Firefox provide the capability of dragging and dropping items into the navigation or sorting the navigation.

Lab 1: Creating a Structured Company Portal

The Learning Lake parent organization has implemented SharePoint 2016 Enterprise, and has hired you to administer the Learning Lake site. In this set of labs, the site collection administrator is responsible for building department sites within the corporate Intranet, creating the necessary document libraries within the Human Resources department site and configuring the navigation to hide unnecessary links to libraries while changing the order in which items appear in the navigation.

After completing this lab, you will be able to:

• Create sites as part of a formal site structure
• Create new apps for documents and lists
• Enable versioning and content approval settings on libraries or lists
• Customize views on libraries or lists
• Configure navigation to hide lists and libraries

Estimated time to complete this lab: 75 minutes

Exercise 1: Creating a New Main Department Site

The Learning Lake Intranet is designed to have a number of areas for collaboration. In this exercise, you will be creating a parent site for all subsequent departmental sites.

1. In the SDG-WIN10 Virtual Machine Connection window, click Action > Ctrl-Alt-Delete to log in.

2. At the login prompt, if you see Jerome Clark, skip to step 4. Otherwise, click the left arrow to the left of the silhouette.

3. Click the silhouette called Other user.

4. Sign in to the SDG-WIN10 virtual machine as the following user:
   a. Username: LEARNINGLAKE\JeromeC
   b. Password: Passw0rd1

5. Click the right arrow to login. (This may take a moment to login for the first time.)

6. Click your browser, such as Internet Explorer in the taskbar. (It may take a moment to get to the Learning Lake Intranet site.) A new window should launch and take you to the Learning Lake Intranet home page.
7. Click **Settings**. (This is the gear wheel near the top right corner.)

8. Click **Site contents**.

9. Scroll down to the **Subsites** section, and click **new subsite**.

10. Type the word **Departments** as the name of the site in the **Title** box.

11. Type **dept** to complete the website address (URL) in the **URL name** box.

12. Click **Team Site** under the **Collaboration** tab in the **Template Selection** area for a template.

13. Keep the default option **Use same permissions as parent site** under **User Permissions**.

14. For **Use the top link bar from the parent site** click the **Yes** radio button.

15. Click **Create** to finish creating your site. (It may take a few minutes for the site to be created.) While the site is being created, the **Create** button will be greyed out and a faint status indicator of a spinning ellipses will render next to the **Create** button. The site is available once you are at the new departments site.
Exercise 2: Creating a New Child Department Site

Each department will have its own collaboration space. In this exercise, you will be creating a site for the Human Resources department.

1. From the newly created department site, click **Settings > Site Contents**.

2. Click **new subsite** under the **Subsites** heading towards the bottom of the page.
3. Type **Human Resources** as the name of the site in the **Title** box.

4. Type **hr** to complete the **URL name** box.

5. Click **Team Site** under the **Collaboration** tab as the desired site template.

   ![New SharePoint Site](image)

   It is a best practice to use abbreviated or short naming conventions for URLs. Also, all URL paths should be free of spaces and special characters.

6. Under **User Permissions**, keep the default option **Use same permissions as parent site**.

7. For **Use the top link bar from the parent site** click the **Yes** radio button.

8. Click **Create** to finish creating your site.
Exercise 3: Create New Apps for Documents and Lists

A top level site collection has already been set up as part of a new installation of SharePoint 2016. When provisioning a new team site, you have a Shared Document library automatically added as part of the site. To create a new custom list within SharePoint, perform the following steps.

1. In the Human Resources site, click Settings > Add an app.

2. Click Contacts under Apps you can add.

3. In the Name box, type Contacts as the name for the list.

4. Click Create to create the list.
5. Click **Contacts** under **Lists, Libraries, and other Apps**.

6. Click **new item** to open the input form for the newly created contacts list. Notice the list of available fields on this list. This will be modified in Exercise 4.

7. Create the following contacts. Each time you create a new contact, click **Edit > Save** from the **Commit** section on the ribbon to save each contact.

<table>
<thead>
<tr>
<th>Last Name</th>
<th>First Name</th>
<th>Email Address</th>
<th>Job Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evans</td>
<td>Linus</td>
<td><a href="mailto:linuse@learninglake.com">linuse@learninglake.com</a></td>
<td>CEO</td>
</tr>
<tr>
<td>Roth</td>
<td>Ali</td>
<td><a href="mailto:alir@learninglake.com">alir@learninglake.com</a></td>
<td>Education Manager</td>
</tr>
<tr>
<td>Vanderbilt</td>
<td>Terry</td>
<td><a href="mailto:terryv@learninglake.com">terryv@learninglake.com</a></td>
<td>Sales Manager</td>
</tr>
<tr>
<td>Clark</td>
<td>Jerome</td>
<td><a href="mailto:jeromec@learninglake.com">jeromec@learninglake.com</a></td>
<td>HR Manager</td>
</tr>
</tbody>
</table>

8. Once you have created your four contacts, click the **SharePoint** logo on the top left to return to the landing page for the **Human Resources** site.
Exercise 4: Modifying Columns on an Existing List

A great way to add new content to your site quickly is to use list or library templates; they contain a set of predefined columns that are automatically added, when the list is created. However, in some circumstances, not all of the predefined columns may be applicable. In this exercise, you will go through the process to remove unnecessary columns created as part of a predefined list.

1. In the current navigation, click the Contacts list you created in Exercise 3.

2. On the ribbon, click List > Settings > List Settings. Notice a section labeled Columns, in the middle of the page, which contains a list of all of the predefined columns created as part of the list template.

3. Click the Company field name to browse to the column properties.

4. At the bottom of the window, click the Delete button.

5. Click OK to confirm the removal of the column from the list.

6. Repeat steps 3-5 to remove the following columns:
   a. Country/Region
   b. Web Page
   c. Notes
When using a predefined SharePoint list, often there are columns that cannot be removed because they either are hidden or are part of the core functionality within the list or library. You will cover content types in a later lab, which will provide instructions on how you can hide columns instead of deleting them.

Deleting columns from the SharePoint list or library only removes them from this instance of the list or library. The columns can be added to the list again as explained in Exercise 5: Adding Columns to an Existing List or Library.

Exercise 5: Adding Columns to an Existing List or Library

In Exercise 4, you removed extra columns that were not needed. SharePoint has many predefined columns that can be added to any list or library, allowing site owners the ability to customize list or libraries based upon a specific business need. This exercise will guide you through steps to add an existing SharePoint column to the contacts list.

1. Your browser should be open to the Human Resource site and navigated to the List Settings for the Contacts list.
2. Notice the links, below the list of columns, in the middle section.
3. Click Add from existing site columns.
4. From the drop-down menu under Select site columns from, select Core Contact and Calendar Columns. Notice the list of Available site columns is filtered to a smaller subset.
5. Scroll through the list and select Department.
6. Click Add to move the column to Columns to add on the right.
7. Click **OK** to add the column to the list.

8. Click the **Column ordering** link below the **Add from existing site columns** link you just used.

9. Change the **Position from Top** value for **Department** to **7**.

10. Click **OK** to save the changes to the column order.
11. On the current navigation, click **Contacts** to return to the contacts list.

12. To see the changes to contacts, click **new item** and notice the number of fields listed has been limited to those columns selected.

13. On the ribbon, click **Edit > Cancel** from the **Commit** group to exit.

14. Click any contact created and notice that the number of fields listed is also limited to the columns selected.

15. Click **Close** to return to contacts.

The **Column ordering** option is misleading because it does not control the order of the columns from left to right in the view. That option is controlled by modifying the view of a list or library.

**Exercise 6: Creating a Custom View**
In Exercises 3 and 4, you created a contacts list and modified it to include a new custom column for the Department library. Notice, when you added the department column, it was added to the view as the last column on the list. In this exercise, you will walk through creating a new custom view for the contacts list.

1. On the current navigation, click the Contacts list you created in Exercise 3. Notice the order of the columns in the view, paying particular attention to the location of the Department column as the last column.

2. On the ribbon, click List > Create View in the Manage Views section.

3. At the bottom of the page, click All contacts below the Start from an existing view section.

4. Type HRContacts as the view name.

5. Click the box Make this the default view.

6. Within the Columns section, click the Attachments and Home Phone boxes to remove them from the view display.

7. Click the drop-down menu for the Position from Left for Departments and change that value to 4.

8. Scroll to the Style section. Click the + by Style to expand the styles. Change the View Style to Shaded.

9. Click OK to create the view. Notice the new order sequence of the columns for this Contacts list. (Department is before Business Phone).

Exercise 7: Updating the Global Navigation

Often, organizations want to control the type of information that resides in the left navigation and global navigation in order to make it easy to find information. In this exercise, you will go through the steps to modify a site’s navigation to add or remove links to content that resides within SharePoint as well as externally. As you add new sites to SharePoint, they may not automatically appear in our global navigation. To adjust the navigation settings to render links to our subsites, perform the following steps.

1. Click the Learning Lake Intranet link at the top to navigate to the Learning Lake Intranet home page.

2. Click Settings > Site Settings.
3. In the **Look and Feel** section, click **Navigation**.

4. Select the checkbox **Show subsites** in the **Global Navigation** settings, and then click **OK**.

![Global Navigation Settings](image)

The setting, **Maximum number of dynamic items to show within this level of navigation**, restricts the number of items that will display in the top navigation.

5. Now, we are going set the same option for the **Departments** site. Click the **Departments** link in the global navigation.

6. Click **Settings > Site Settings**.

7. In the **Look and Feel** section, click **Navigation**.

8. Select the box next to **Show subsites** in the **Global Navigation** settings, and then click **OK**.

Observe that the **Departments** link in **Global Navigation** has a drop-down which, when hovered, displays the subsite **Human Resources**.

9. On the global navigation bar, click **Learning Lake Intranet**.

**Exercise 8: Updating the Current Navigation**

Every time a new list, library or site is created, the navigation for the site is updated to include links to the new content. In this exercise, you will go through the steps to adjust the information that appears in the current navigation or left navigation.

1. At the top of the page, hover over **Departments** and click **Human Resources** in the global navigation.

![Departments Link](image)

2. Click **Edit Links** in the current navigation on the left.
3. Click the X next to Documents from the current navigation to remove the link to that library.

4. Click and drag the Contacts list, so that it appears directly below Home.

5. Click the X next to Recent.

6. Click OK in the confirmation window, if applicable.

7. Click Save to finalize the changes and switch out of edit mode.

Lab 2: Creating a List Using SharePoint Designer (Optional)

While you can create lists through SharePoint, doing many at one time can be inconvenient. SharePoint Designer is better suited to making many changes at once while reducing the overall number of clicks it will take to create these objects.

At completing this lab, you will be able to:

- Open a Site in SharePoint Designer
- Create a custom list in SharePoint Designer
- Add columns to a custom list in SharePoint Designer

Estimated time to complete this lab: 15 minutes

1. From the computer's taskbar, open SharePoint Designer. If this is your first time starting SharePoint Designer, in the First things first dialog box, select Ask me later.

2. From the Sites page, click Open Site.

3. From the Open Site dialog box, next to Site Name, type http://intranet.learninglake.com.
4. Click **Open**.

5. If prompted for credentials, enter the following username and password. (You may be prompted twice.)
   
   a. **Username**: *Administrator*
   
   b. **Password**: *Passw0rd1*

6. In the **Navigation** pane, under **Site Objects**, click **Lists and Libraries**.

7. On the ribbon, click **List and Libraries > Custom List**.
8. For **Name**, enter **Products** and click **OK**.

9. From the **List and Libraries** tab, click **Products**. The **Products** page will then appear.

10. On the ribbon, click **List Settings > Edit Columns**. You will now add a few columns.

11. On the ribbon, click **Columns > Add Existing Site Column**.
12. From the **Site Columns Picker**, click **First Name** and then click **OK**.

13. On the ribbon, click **Columns > Add New Column** drop-down.

14. Click **Single Line of Text** for the data type.

15. Rename the column, **Last Name**.
16. Click **Add New Column** to add a column, and click **Choice** as the data type.

![Add New Column and Choice Data Type](image)

17. In the **Column Editor**, under **Choices**, enter the following:

   a. **Minneapolis**
   b. **Seattle**
   c. **San Francisco**

![Column Editor with choices](image)

18. Delete **Choice 1** from **Default value**.

19. Click **OK**.

20. Rename the new column **Location**.

21. On the ribbon, click **Columns > Add Existing Site Column**.

22. From the **Site Columns Picker**, click **Mobile Number**.
23. On the Quick Launch, click **Save**.

24. Switch back to SharePoint in your browser, and type **http://intranet.learninglake.com**.

25. Click **Settings > Site Contents**. The new **Products** list should appear.

26. Click **Products**.

27. From the **Products** list, click **New Item**. Notice the columns you added are visible. Leave the **Title** (that comes with the list by default) column as is.

28. Click **Cancel**.